App crashs when downloading updates and and stalls loading

Been trying to use the app and it crashes multiple times when downloading and then when i actual get all the packets downloaded the app just says loading. I left it loading for multiple hours and still doesn’t progress. I using the app on ASUS Chromebook. I tried uninstalling & reinstalling the app and it doesn’t work. Can any help me?

Hello. I just figured I’d preemptively help troubleshoot before somebody from Privateer asks. :slight_smile:

What version of the app are you trying to install?

The current version that was released (I believe) on the 18th is Version 1.2.05. The release notes for that version mention “Fixed startup with no network connectivity getting blocked at login.”

I don’t know if that is the version you have, or the specific issue you’re having, but providing the version number in use is a start. :slight_smile:

So the google pay store doesn’t give me a version number but it says it was updated on Dec 12 2023.

It’s possible they simply haven’t tested it on a Chromebook and there’s some compatibility issue. I would recommend sending an email to feedback@privateerpress.com with as much information about your hardware and software as you can provide.

App still doesn’t work on my android (samsung S9)
stuck on “loading”
if starting in flight mode you can actually get some clickable menu but as soon as you use the login you’re stuck on loading again
If uninstalling+rebooting it clearly doesn’t uninstall completely as it retain login info

Just wanted to know if you managed to fix it?

I can’t speak for the OP, but odds are good that it’s a matter of:

  • Uninstall
  • Clear your data cache (in case your login credentials are cached, etc.)
  • Reinstall

I had this sort of issue a few months back and that fixed me. That’s also essentially the same fix that’s worked in all the Facebook discussions I’ve seen. :slight_smile:

Tried that, and more (including installing on a ‘fresh’ phone)
In the end the problem seemed to be caused by the combo of my android account and the app. So I reinstalled my phone with a different google account. :slight_smile:

1 Like

I’m glad you got it fixed. :slight_smile:

Defiantly not a problem I’ve head about before. Def report that through the app if its working now. Hopefully we can find out what is going on.